Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 24, 2026 - 23:00 CET
Scheduled
We would like to inform you that our website and mobile application will undergo scheduled maintenance on February 24th starting at 22:00 UTC. The maintenance is expected to last approximately 1 hour.
During this time, access to both the website and the mobile application will be temporarily unavailable.
We apologize for any inconvenience this may cause and sincerely appreciate your understanding and patience as we work to improve our services.
Thank you for your continued trust and support.
Posted Feb 24, 2026 - 10:34 CET
This scheduled maintenance affected: CMMS (Login, Tasks, Maintenance Plans, Imports, Partners API, iOS Mobile Application, Android Mobile Application, Mail).