Incident app down - under investigation
Incident Report for Mobility Work
Resolved
This incident has been resolved.
Posted Mar 24, 2021 - 12:01 CET
Update
We are continuing to investigate this issue.
Posted Mar 24, 2021 - 11:47 CET
Investigating
We are currently investigating this issue.
Posted Mar 24, 2021 - 11:46 CET
This incident affected: CMMS (Imports, Maintenance plan, Public API, IOS app, Android app).